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Introduction  
 
GC-PowerStation provides multiple editing tools that allow complex functions to be easily 
completed. Sharing the same user interface and GWK structure as GraphiCode’s industry leading 
Gerber viewer (GC-Prevue) it provides outstanding value for customers. 
  
You will discover as you navigate through the demonstration guide that GC-PowerStation will 
save you time and money. This tutorial will focus on the major areas of the software that a new 
user needs to understand and but cover only selected functions.  Please do not hesitate to 
contact Graphicode or your authorized GraphiCode reseller at any time throughout this demo if 
you have questions. If you have obtained this Demonstration Guide from GraphiCode directly, 
please call 360-282-4888 or email us at sales@graphicode.com. 
 

Recommended System Configuration 
This demonstration guide assumes users have a working knowledge of MS Windows. 
 
1 GHz Pentium or equivalent preferred 
Windows 2000, XP, Vista and Windows7 all currently supported 
512 MB RAM min. 2 GB+ preferred  
2 GB+ hard disk 
Windows accelerator video card with 256MB or more video DRAM 
17” or larger monitor, 800x600 or greater resolution 
 

Symbols and Hints to using the Guide 
 
This symbol  > represents “find and select”. 
All menu options are displayed in Bold Italics 
Example: Choose File > Import means choose File from the main menu then select Import. 
 

Files required for using the Guide 
 
General Navigation.GWK  Aperture.rep 
Silkbot.gbr:     Silktop.gbr 
Bottomside.gbx    Topside.gbx 
GC-conv-aper.zxz   Bottom mask.gbr 
Top mask.gbr    Ncdrill.drl 
Four_layer_example.gwk  my_demo_4layer_foil.cfg 



Chapter 1: Basic Navigation 

Loading a GWK 
All GraphiCode products (GC-PowerPlace with Test, GC-PowerPlace, GC-PowerStation, GC-
CAM Edit, GC-PrevuePlus and GC-Prevue) save data in the GWK file format. This file format is 
forwards compatible and allows information to be easily transferred. A GWK file can contain 
printed circuit board layers, names, aperture lists, drill lists, BOM, editing changes, and feature 
settings. For this first lesson we have already loaded the raw Gerber data files for you and saved 
the information in a GWK file – later lessons will deal with loading many different types of Gerber 
and Drill information.  
 
We will now spend a little time learning the major areas of the software by loading a GWK file and 
performing some simple tasks. 
 

1. Start GC-PowerStation 
2. From the main menu choose File > Open 
3. Use the file picker to navigate to the ‘Demodata’ directory within the installation directory. 
4. Select the General Navigation.GWK then select Open 

 
A graphical representation of the physical board appears on screen (see Figure 1).  
 

   

Navigation View 

  
Minimize/Maximize/Close 

GC-Explorer 

Use the Tools > 
Customize > File 
Locations tab to set 
the default path for 
Job Files 

Figure 1: Loaded Data 

Saving 
Any changes made to the GWK can be saved by selecting File > Save (to save an updated 
version of the current file) or by using File > Save As… (to rename the updated file). 

Navigation – Zoom 
On many occasions, you will want to enlarge or reduce an area of the board for better viewing. 
Let’s experiment with the zoom features of GC-PowerStation. 
 

1. Figure 1 highlights Navigation view. This window gives a bird’s eye view of the current 
graphical display with reference to the data extents. 

2. Click on the Maximize button to maximize the current graphical window. Note how the 
Navigation View updates. 

3. Click the right mouse button to obtain a list of options and choose Zoom to Extents (see 
Figure 2). 



        
Figure 2: Right mouse button menu 

4. The displayed data is then automatically fitted within the current graphical window. 
Zooming to Extents will always display the current visible data within the window at the 
lowest zoom level. 

5. To zoom in, drag a window with your left mouse button around the area you wish to 
investigate. You will then see a pop-up menu that allows you to Zoom In. (The Zoom to 
Window option creates a new window at the new zoom and is best seen when graphical 
windows are not maximized). 

6. To zoom out, click the right mouse button and select the Zoom Out option. 
7. To zoom to the previous zoom level, click the right mouse button and select the Zoom 

Previous option. 
8. If your mouse has a mouse wheel, rolling the mouse wheel away from you will zoom in 

and towards you to zoom out. 
9. Continue to experiment with the zoom features. Note: For users of GC-Prevue v8.x or 

earlier you can still double right click to zoom out if you change the setting in Tools > 
Customize > Edit dialog. 

10. All Zoom features can also be located under View > Zoom along with current hotkey 
settings. 

11. When you are finished exploring, choose Zoom Extents to mirror Figure 3 
 

 
Figure 3: Zoom Extents 

GC-Explorer 
The GC-Explorer window contains information about all layers in the GWK file. Layers are divided 
into three distinct types. 

 
1. Holes/Routs – These layers represent any drill holes or rout path information 
2. Physical Layers – These layers represent the physical layers of the board and have a 

layer type definition. Physical layers can consist of one or many data layers allowing the 
combination of positive data and negative ‘scratch’ data within a single layer. 

3. Unassigned layers – These layers are all remaining layers either not assigned as 
Physical Layers or layers not necessary to prepare an assembly program.  

 



The properties for any layer can be viewed by double clicking the layer in the GC-Explorer 
window. They can also be viewed by selecting the layer with the left mouse button and clicking 
the right mouse button and selecting Properties. 
 

1. Select the Physical Layer P2 “Comp” top with the left mouse button 
2. Click the right mouse button and select Properties. 
3. The Properties tab is displayed 
4. You can see that the properties for a Physical Layer include such attributes as Layer 

Name, Layer Type, Side, Layer Colors, and Visibility. Feel free to change some of the 
properties, select Apply and note their effect in the GC-Explorer window.  

5. The GC-Explorer list in the left pane of the dialog allows other layers to be selected and 
changed as required. 

6. Select OK to come out of the GC-Explorer dialog. 

View/Hide/Edit 
One attribute that is very useful to change is the Visibility Status of a layer. Layers can be edit-
enabled (edit), hidden (hide) or visible (view). These different settings provide security by 
enabling you to only change layers that are edit enabled. If a layer’s status is set to view or hide, 
data on that layer cannot be edited.  
 

1. Select View > Layers > Hide All. You will see all data disappear from the graphical 
window and all layers in the GC-Explorer window will now have the (h) status indicating 
they are hidden.  

2. Now we will set Physical layer P2 to Edit status in preparation for editing. Select the 
Physical layer P2 using the left mouse button and then use the right mouse button to give 
the drop down menu and then select Edit. You will now see the GC-Explorer name is now 
shown in bold with the (e) attribute indicating Edit enabled status. The graphics screen 
will not refresh until you click back in the graphics window as this allows you to set the 
View/Hide/Edit status of other layers without having to wait for redraws. 

 
You may have noticed that the hotkey for setting a layer’s status to edit-enabled was E (V for 
View and H for Hide) so now try experimenting by selecting a layer in the GC-Explorer and using 
the hotkey to rapidly set layer visibility.  
 

3. Also try setting layer visibility when the Physical Layers branch is selected (as shown in 
Figure 4). You will notice that the change applies to the parent and the children (see 
Figure 5).  

 

             
Figure 4: Highlighting the Parent  Figure 5: All Physical layers in Edit            

4. After gaining a better understanding of how Hide/View/Edit status is controlled, Select 
View > Layers > Hide All to hide all layers and then make Physical layer P2 Editable by 
selecting that layer and hitting the Hotkey ‘E’. 

 
 

 



 

Selecting Data 
 
Many functions within GC-PowerStation work with data that has been selected. This allows 
certain features on a layer to be worked upon without affecting the other data on the layer. 
Selection of data can only occur on a layer that has edit-enabled status set. 
We will now investigate some methods of selecting data – based on having all layers in the Hide 
mode EXCEPT for P2, which is in Edit mode. 
 

1. Choose Edit > Select All. The data should turn White indicating that the data is selected. 
Note also that the Co-ordinate Summary Window indicates the number of Pads and Drills 
and Routs and Traces selected (see Figure 6). This is always a useful place to check to 
ensure that data is not unintentionally selected. 

 
 

Figure 6: Co-ordinate summary 
 
2. Zoom in on a selected area (see the preceding section for how to zoom in) and we will 

look at unselecting and reselecting data. Ensure that a number of entities (pads and 
traces) appear large enough on screen so that it is clear when the crosshair is positioned 
over an entity. 

3. Now use the Left mouse button to deselect a currently selected entity. You can reselect 
the feature by using the left mouse button. The left mouse button toggles the selection of 
data in an edit-enabled state. 

4. Holding down the Control button while selecting with the 
left mouse button will deselect all data prior to selecting 
the entity under the cursor. This is a quick method of 
ensuring that the selected data is the only entity selected.  

Use the Tools > 
Customize > Edit tab 
to turn off left mouse 
button selection if you 
prefer 



5. To select an area, drag a box with the left mouse button and either choose the option 
Select Touching or Select Inside. The Select Touching option will select data that is 
both completely or partially within the box. The Select Inside option will select data that is 
completely within the box. The same also applies to the Unselect Touching and 
Unselect Inside options.  

6. After experimenting with the above methods of selecting, choose Edit > Unselect All. 
You should have zero values in the Co-ordinates Summary window for selected data. 

7. Now move your cursor over an entity and click the right mouse button. Choose the Select 
this Tool function. A tool simply refers to an entry in an aperture or drill table. Any 
occurrence of this tool should be selected. (If this is not the case make sure that the 
cursor and the crosshair are joined by hitting the space bar). 

 

      
Figure 7: Select This Tool - Before   Figure 8: Select This Tool – After 

 
8. The Unselect this Tool function can be used in the same manner. 
9. The Edit > Select > Filter Selection option also allows for entities to be selected or 

unselected based on size, shape, D-Code. 
10. When you are happy with the idea of selecting and unselecting data choose Edit > 

Unselect All. 

Query and Status Bar 
It is often useful to know some of the information about an entity such as D-Code, size, shape, 
and position as well as reference designator, part number, and package type. GC-PowerStation 
provides that information in a quick and easy-to-understand way. 
 

1. Simply move your crosshair over the entity that you wish to investigate.  
2. View the Status bar along the bottom edge of the application (see Figure 9) to find out 

information about that entity including Layer, Aperture size and Shape, Position, Part 
Number, Reference Designator and other useful information. Note, the information varies 
with the type of entity being investigated (Pad v Trace v Drill v Part) 

 

 
Figure 9: The Status Bar 

3. If multiple items need to be investigated then the Query function can be used. The Query 
function works on selected data so make sure that a number of items are selected.  

4. Select Tools > Query and the Query window will appear (see Figure 10) 
5. The list of selected items is shown along with a graphical window showing the item, the 

navigation view and the Properties of the current item. Pads, Traces, and Parts are 
separated and displayed by making a radio button selection in the bottom left corner. 

6. Features such as Auto Zoom and Zoom In and Zoom Out make changing the graphical 
view straightforward. Auto Zoom makes the transition from viewing large objects to small 
objects easier. 



 
   Figure 10: The Query Window 

Properties 
Page 
 
 
 
 
 
 
 
List Control 

 
7. The Properties page can be used to change information associated with the entity. 
8. To close Query select the OK button. 
9. You can now Close this GWK dataset (without saving) in preparation for loading some 

Gerber files and performing edits. Select File > Close and select No. 



Chapter 2: Loading Gerber data 

Importing Gerber data 
The dataset that we will use to illustrate many of the features of GC-PowerStation has been 
adapted to include some RS-274-X files (Extended Gerber), some RS-274-D files, some aperture 
lists that convert automatically, an aperture list that needs manual conversion, and some drill 
data. Gerber data will normally arrive in a consistent format for each job and it is important to 
understand that this dataset is purely meant to illustrate each of the common file types you may 
encounter. 
 

1. From the menu choose File > New 
2. From the menu choose File > Import 
3. The standard Windows file picker dialog appears. Navigate to the ‘Demodata’ directory 

within the installation directory. Select the following files using the standard Windows 
selection techniques of using the Control button and/or Shift button: 

 
Aperture.rep: A recognized aperture format 
Silkbot.gbr: Bottom silkscreen Gerber file (uses Aperture.rep) 
Silktop.gbr: Top silkscreen Gerber file (uses Aperture.rep) 
Bottomside.gbx: Bottom Signal Extended Gerber file (apertures embedded in file) 
Topside.gbx: Top Signal Extended Gerber file (apertures embedded in file) 
GC-conv-aper.zxz: Aperture File that requires conversion 
Bottom mask.gbr: Bottom soldermask Gerber file (uses GC-conv-aper.zxz) 
Top mask.gbr: Top soldermask Gerber file (uses GC-conv-aper.zxz) 
Ncdrill.drl: Drill file 

 
4. Hit Select when you have selected the required files. The program now automatically 

recognizes file types and formats. 
5. You will see the Import – Verify File Information dialog. You will notice that all file formats 

except for the GC-conv-aper.zxz file have been reported as successfully recognized. You 
can alter the width of each column by dragging on the column header. Also, we need to 
change the formatting of the NCDrill.drl to be Trailing Zero suppression rather than 
Leading Zero Suppression. To accomplish this, select the NCDrill.drl entry and right click 
to display the pop-up menu. Choose Modify Format Parameters and change the ‘Zero 
Suppres.’ setting to Trailing from the drop down list. This dialog also allows the unit 
format to be changed. Press OK. 

6. In order to convert this unrecognized aperture format we select from the Drop-down list 
that is accessed through the down arrow in the File Type field (see Figure 11) and 
choose Aperture List. 

 



 
Figure 11: Verify File Information 

 
7. When the format is chosen, the Tool Table Assistant is automatically started, and the file 

is interrogated to see if its format matches an existing format. If the match is successful 
then the conversion is reported in the same way as the Aperture.rep file. If conversion is 
unsuccessful, the Tool Table Assistant is displayed.  

8. The File Type is set to Aperture Table by virtue of your choice from the drop down list. 
Original data type is set to Delimited (some character or whitespace delineates different 
fields). Change the Start Import at row: field to read 5. Select Next. 

9. Enter the values (as shown in Figure 12) to correctly assign different fields to their correct 
value. The delimiter in this case is whitespace (i.e. whitespace separates different fields) 
and the field number for each value can be easily seen. Take care to ensure that units 
are correctly set to inches. 

 

 
Figure 12: Tool Table Assistant 

 
10. Select Next. 
11. The next dialog allows the assignment of GraphiCode standard aperture shapes to the 

keywords used in the aperture file. In this case, descriptions are clear and there is 
nothing to change. Select Next. 

12. The final dialog allows the format information just entered to be memorized and re-used 
on further aperture files of this format (use the Memorize button). For this demonstration 
we will not do this but rather simply select Finish. You are then prompted to save the 



converted file as an external file (can then be re-input at any time without requiring 
conversion). Select No and you will be returned to the File Verify File Information dialog 
but now you will see that the GC-conv-aper.zxz now has a Green Checkmark next to it 
and the 35 tools have been successfully converted. (NOTE: You also have the option to 
Import DXF and DWG file formats using the File Import menu item). Select OK. 

13. The Assign Tool Tables dialog appears. This dialog is used to assign an aperture table to 
the file that requires it. In this example, we have two aperture lists, each used by two 
Gerber files, two files (the RS-274-X extended Gerber files) which generate their own 
aperture tables and a Drill file (which generates its own Tool table). Again, use the drop 
down box to correctly assign the aperture tables. The files Silktop.gbr and Silkbot.gbr 
need to use the Aperture.Rep file and the Top mask.gbr and Bottom mask.gbr need to 
reference the GC-conv-aper.zxz file. All other layers are fine as they are. See Figure 13. 

 
Figure 13: Aperture Table Assignment 

 
14. Select OK and the layers will start to load and you will see layers being created in the 

GC-Explorer area. Once loading is completed, you will the File Import Result Dialog. 
15. There are three tabs: File, Errors, and Tools.  

a. File Tab – Double paned properties page, the right side of which allows you to 
name the layer, set the layer type, change the pad and trace colors for the layer, 
and change other properties of the Physical layer. 

b. Errors Tab – Lists any problems with any of the layers loaded. For example, any 
calls within the Gerber file for an aperture that is not present in the used aperture 
list will be shown in this tab. 

c. Tools Tab – Shows the Aperture Table or Drill Table that is being used by the 
layer being investigated. 

16. Select OK when you are ready to continue and you will see the loaded Gerber data on 
screen ready for the next section of the demonstration. 

 

Aligning Data 
 
You will notice that the Drill layer is misaligned with the Gerber data. We will now move the Drill 
layer to align with the Gerber files, thus correcting the problem. GC-PowerStation allows the 
movement of individual selected entities or groups of entities. Here, we will offset the entire drill 
layer.  
 
The layer(s) to be offset must be in Edit mode and must also have data selected. 
 

1. Select View > Layers > View All. 
2. Now set the drill layer (H.1) to Edit status in preparation for offsetting it to the Gerber 

data. 
3. Click back in the Graphics Window, right click and Select All (we are now ready to move 

the entire drill layer). 



4. Move the cursor and crosshair near to a feature that will be the reference point (this will 
be a drill hole that can be aligned to a reference point on one of the other layers). 

5. Use the Jump Nearest feature (located in the Edit Menu - hotkey is "S").  This will jump 
your cursor to the nearest feature.  Then Zero Relative (located in the Tools menu - or 
hotkey "Z").  This sets your Relative Zero coordinates to 0,0. The Relative distance now 
displayed in the Co-ordinate Summary dialog measures the position of the crosshair from 
the zero position. The zero position is the center of the drill hole. if we move our crosshair 
to the center of the pad upon which this drill hole needs to be placed, we will know the 
distance to be moved by reading the Relative Distance in the Co-ordinate Summary 
dialog.  

6. You will notice that the crosshair is now fixed, and only the cursor moves with the mouse.  
Re-attach (carry) the cursor and crosshair by pressing the Space bar. 

7. Move the crosshair and cursor to the corresponding point on the reference layer and 
Jump Nearest to that point. 

8. Select Move To Offset (located in the Edit menu - Hotkey 'O') and the relative distance 
will appear as the default.  Press Enter and the data should move accordingly.  

9. As all the data on the drill layer was selected prior to moving, all data has moved by the 
same amount. NOTE: Remember that you can also select specific entities and move only 
those entities.  

10. Right click and Unselect All to ensure that all data has been unselected. 

Chapter 3: Editing data 
 
We will now make measurements, make an amendment to pad shape, delete some data, step 
and repeat data and output an RS-274-X file. GC-PowerStation can also perform many other 
tasks regarding the data and we leave it up to you to investigate the other menu items. 
 
For On Line Help simply hover over the menu option and hit F1. 
   
Firstly we will return to the earlier GWK to ensure the images in this demonstration guide are 
consistent. 
 

Measure 
 

1. From the main menu choose File > Open 
2. Use the file picker to navigate to the ‘Demodata’ directory within the installation directory. 
3. Select the General Navigation.GWK then select Open 
4. Select View > Layers > Hide All. You will see all data disappear from the graphical 

window and all layers in the GC-Explorer window will now have the (h) status indicating 
they are hidden.  

5. Now set Physical layer P2 to Edit status in preparation for measuring (although we can 
also measure in View mode), editing and step and repeating. 

6. Zoom in so that you can see a number of objects that you are interested in measuring. 
We will use a row of pads from one of the devices on the board and take measurements 
of separation and of pitch. 

7. In the graphics window, right click and choose the option Switch mode to... and then 
select the Measure option. 

8. You will notice a number of things – the cursor has changed to indicate a different mode 
and also the Co-ordinate Summary has changed in preparation for displaying measured 
values (see Figure 14). 

 



 
      Figure 14: Measuring 

 
9. The order of selecting the entities for measuring is important for the following reasons. 

a. Measurements are given for Edge to Center and Center to Edge. The order of 
selection will affect which is the desired result 

b. Measurement only occurs between two objects. A third object will shuffle the 
previously selected objects down. This is best shown by example. 

10. Click on an object on screen. You will see the Co-ordinate Summary register one object 
defined. 

11. Click on a second object and the measurement will be given in the Co-ordinate Summary 
and also graphically. You can change the measurement reported in the Co-ordinate 
Summary window. 

12. Next, click a third object. You will now see how the objects shuffle down. The last two 
defined objects are now the measured objects. 

13. The other possibility is that you wish to make multiple measurements from a reference 
point. In this case, select the reference point first and then choose the second measure 
point. Hit Escape and this will remove the second defined object (but retain the reference 
point), leaving you free to define the next measure object.  

14. Hitting the Escape key twice will remove both defined objects and hitting it a third time 
will return you to the Normal mode. You can also change back to the Normal mode at any 
time by right click, Switch Mode to … Normal. 

 
 
 

Editing Data 
 
Let’s make changes to some of the pads that comprise the device we have been measuring and 
then let’s delete the targets and text box from the layer prior to creating an array. 
 

1. In Normal mode, select a pad or two. They will turn white. Right click while the crosshair 
is over one of the pads and select Properties. The Properties page appears (Figure 15). 

 



 
Figure 15: Properties Page 

 
2. In the properties page you can change the size and shape of the selected pad. If the 

Apply to all button is checked, then the changes made will apply to all identical selected 
pads. (Identical means they share the same aperture (a001.60 in the above figure)). In 
this case let’s make the shape oblong. 

3. A different set of attributes will be presented depending on whether the data under the 
crosshair is a pad, trace, or drill. 

4. When changes have been made, make sure that all data is unselected (right click and 
Unselect All) before moving on. 

 
 

Deleting Data 
 
Deleting unwanted data is very straightforward in GC-PowerStation. In order to delete, the layer 
that contains the data to be deleted must be in Edit mode and also, the data to be deleted must 
be selected. Once you have selected the data, go to Edit > Delete and the data is removed.  
 
Deleting data in this way has no affect on the aperture table. 
 
If you prefer to keep a copy of the deleted data around you can use Edit > Cut and Edit > Paste 
to… to move the cut data to its own layer. Tip: When the Paste to… dialog asks you for a layer 
enter U.New and the data will be stored on a new Unassigned layer. 
 
 

Step and Repeat / Panel Array. 
 
A single image (such as we have been looking at) may be arrayed with GC-PowerStation. The 
most straightforward array pattern (and the one described below) is an m x n pattern. The array 



function once again applies to selected data. It can therefore be used not only for arraying layers, 
but also for arraying sections of layers, down to a single pad. 
 

1. Select View > Layers > Edit All. You will see all data appear from the graphical window 
and all layers in the GC-Explorer window will now have the (e) status indicating they are 
edit ready. 

2. Highlight layer P16 (the Fabrication drawing) in the GC-Explorer and set its status to 
Hide. We will not array the Fabrication Drawing. 

3. This example will create a 2 x 3 array with a 0.3 inch gap between images in the x plane 
and a 0.5 inch gap in the y plane. The values we will enter can easily be found by 
measuring from the lower left corner of the board to the upper right corner and adding the 
desired gap. 

4. Click into the Graphics window and right click on the mouse. Select Select All and all 
data on screen should turn white. 

5. Select Panel > Array Copy and Paste. 
6. Enter ‘2’ in the X copies 
7. Enter ‘5.675’ inches in the X step 
8. Enter ‘3’ in the Y copies 
9. Enter ‘4.000’ inches in the Y step 
10. Select OK. 
11. Right click and Unselect All. 
12. Right click and Zoom to Extents 

 
The array pattern is now created. The data has been copied to make the array. This means that 
each individual image can be edited if necessary. 
 
More complex array patterns can be created by combining the Array Copy and Paste function, 
the Rotation function and Move to Offset function. If the array copy and paste is performed when 
in Layers (Panelize) mode (see On Line Help for details) the array consists of virtual copies of the 
original – allowing changes made to the original to automatically update the other images in the 
array. 
 

Converting Sketched Pads. 
 
These two functions perform the task of converting drawn data into flashed data. The following 
steps will use both functions to convert a solderpaste layer of traces into a solderpaste pad layer. 
The Auto Convert Sketched Pads would normally be used on the entire layer but for the purpose 
of also demonstrating the Advanced Scan and Replace function, we will only run it on part of the 
layer. 
 

1. From the main menu choose File > Open 
2. Use the file picker to navigate to the Examples directory that is a sub-directory in the 

Installation directory. (For a GC-PowerStation V x.x.x standard installation this would be 
in C:\Program Files\GraphiCode\PowerPlatform x.x.x\GC-PowerStation\Examples). 

3. Select the Loaded.GWK then select Open 
4. Select View > Layers > Hide All. You will see all data disappear from the graphical 

window and all layers in the GC-Explorer window will now have the (h) status indicating 
they are hidden.  

5. Now set Unassigned Layer U.3 to Edit status in preparation for converting some of the 
features that look like pads but are constructed using Traces. 

6. Highlight U.3 in the GC-Explorer tree, right click and choose Properties. You should 
receive the Properties page for this layer (alternatively you can double click P3). In the 
Properties page you will see two small drop-down boxes of color that are grouped 
together – one is the color of Pads, the other is the color of traces. Click the drop down 
box next to pad: to change the color of the pads on the layer. Make sure that the pads 
and the traces are different colors. Click OK and then click in the graphics area. You 
should see that the pads and traces are now displayed in different colors. 



7. The reason for converting a trace or traces into a pad is because pads are easier to edit 
in many cases and can be used to create other data (for instance the locations of pads 
can be used to aid in the creation of a drill file). 

8. Zoom in to better view an area that contains a number of SMD ‘pads’ (note that they 
should be drawn using the Trace color because they are, in fact, not pads but traces). 
Use your selection tools to select a number of these features (Figure 16 shows an 
example of a selected area). 

 
 

  
Figure 16     Figure 17 

   
9. Select CAM > Auto Convert Sketched Pads. As the layer we are working on is a 

Solderpaste layer you can enter U.3 into the Top Solderpaste layer field (or alternatively 
use the layer picker). Note that because both the top and bottom signal layers have been 
defined as Physical layers with a layer type and side, these layers are automatically 
entered in the dialog. Also note that there will be no action taken on these layers as there 
is no selected data on either of these layers. If the Top Solderpaste layer was placed in 
the Physical layer section (using drag and drop for instance), and assigned with correct 
layer type and side, this layer would also automatically appear in the dialog box. 

10. Select OK. You will see that the selected pads have been converted to pads (as shown in 
Figure 17. 

11. Now we can use Advanced Scan and Replace to convert the remaining ‘pads’ on the 
layer. Zoom in to an area that contains a number of SMD pads (note that they should be 
drawn using the Trace color (green in Figure 17) Click on ONE of these traces so that it is 
highlighted 

12. Select CAM > Advanced Scan and Replace…. You will see the Advanced Scan and 
Replace dialog appear. This dialog asks for a tolerance to use when converting and the 
required ending pad shape. The tolerance value defaults to zero.  This means we are 
going to find an exact match to the selected data with no tolerance variation.  A custom 
pad is an exact match to the taught data and can be utilized when no standard pad 
shapes are required. The custom pad requires a name, a default unique name is 
provided based on date and time of creation.  This is user definable and can be changed 
to any name the user desires. In most cases (and in this example case) it is better to use 
the simplest pad shape to describe the ending shape. Using Rectangle, Round, Oblong 
etc will result in a pad being created of the exact dimension that can then be further 
edited as necessary.  

13. In many cases a drill file can be created by creating Round pads from, say, a DXF file 
which has drawn the drill locations using traces.  

14. Selecting OK will scan the entire layer for the same construction and convert that 
construction to a pad. The changed data is highlighted (we also scan in 0, 90, 180 and 
270 degree orientations to make conversion faster) after conversion. When you right click 
and Unselect All you should see that the features are now the color of the pads.  

15. Use this function a number of times to become familiar with its operation and be aware 
that whatever data is initially highlighted will form the basis for the searched construction. 
TIP: Sometimes it is better to go to Ball and Stick mode when initially selecting your 
starting construction. 



 

Isolation 
 
Isolation is a function that creates a path around the edge of all selected features. This is useful in 
a number of situations including generating a laser stencil cut path around a feature, simplifying a 
complex fill pattern, and reducing the size of complex features. 
 

 
1. Continuing to work on the above solderpaste layer, we will now create an isolation path 

around all features on the layer using a polygon aperture and increasing the size of the 
original by 1 mil on each edge. The isolation path will be created on a new layer and the 
result compared to the original layer. A polygon aperture will automatically fill the 
resulting outline. 

2. Click into the Graphics window and right click on the mouse. Select Select All and all 
data on screen should turn white. 

3. Choose CAM > Isolate. The Isolate dialog will appear. Select the Use Rounds option (for 
case where a laser cutting beam is not circular, you can also isolate with an oblong 
aperture).  

4. Change the units to inches (if necessary) and enter a value of 0.001” in the field for 
clearance. This will increase the size of the feature by 0.001” on each side making a 
0.002” increase overall. NOTE: A negative sign means that the resulting path will be 
smaller than the original edge. 

5. Ensure Force Isolation is turned off, that the New Layer is set to U.New (a new layer in 
the Unassigned layer section), and then choose OK. 

6. In the next dialog choose the file picker arrow. This then takes you to the Aperture List for 
you to choose the aperture with which to create the path. Choose ‘New Aper’ from the 
button options and then set the Aperture Type to Interior Polygon and hit OK. Select OK 
again and you should then have a number in the ‘Aperture for Isolating’ field that 
corresponds to the aperture position of the newly created polygon aperture. This 
management of apertures is automatically handled by GC-PowerStation. 

7. Select OK and then Unselect All. You should then see the increased size of the new layer 
when compared to the original data. This New layer can also be isolated if required and 
please feel free to isolate the data again with different clearance values and apertures to 
observe the results. 

 

Netlist Extraction 
 
GC-PowerStation’s netlist calculator is a very powerful contour based algorithm which has the 
flexibility to calculate net connectivity independent of the number of positive/negative interactions, 
the number of copper layers, or the presence of complex polygon interactions.  
 
Test points are allocated to flashed pads allowing test locations to be determined and therefore it 
is important to ensure that both the outer layers of the PCB contain pad information (see the 
Converting Sketched Pads section for more information). The netlist engine also works on 
electrical layers that are visible on screen in order to allow netlists on a per layer basis or on a 
sub-set of the final PCB’s layers. In order to calculate the netlist for the entire board simply put all 
layers into Edit mode. Layers with Physical Layer type of Soldermask and Silkscreen are ignored 
for the purpose of netlist connectivity with only Signal and Drill layers taken into account. Clearly 
the plated status of the drills is important to know and set prior to netlist extraction as a hole 
defined as non-plated will not provide Z-axis connectivity.  
 
There are three stages in the netlist extraction process: Connectivity, geometric definition and 
accessibility. 
 



Connectivity 
 
Consider the track shown below. The Red layer represents the copper artwork and the blue 
oversized pad, the soldermask opening. In terms of connectivity it is pretty clear that Point A 
connects to Point D. 
 

 
Figure 18 

 
Geometric Definition 
 
Point A and Point D are the end points of this example net (Points B and C are midpoints). To 
efficiently test this net for an open circuit the net should be tested between Point A and Point D. 
Other geometric definitions are Isolated and Loop.  
 
Accessibility 
 
However, Point D does not have an associated soldermask opening and so testing at Point D will 
not contact the copper. Therefore, the next best testable location becomes Point C.  
 
When a netlist is extracted, every pad on the outer layers of the board is assigned a Net Number 
(indicating connectivity) and Test point attributes describing the Geometric definition 
(E(nd),M(id),I(solated), and L(oop)) and Accessibility (T(estable) and C(overed)). 
 
With the layer properties set correctly, plating status, and all layers on screen go to Test > Extract 
Netlist. 
 
 
 
 
 



DFM 
 
Detecting potential manufacturing problems before they occur is critical. The DFM suite of checks 
allows numerous individual checks to be run on data to ensure potential manufacturing issues are 
found up-front. When using the DFM functionality it is important to understand and be aware of 
the following points: 
 

DFM checks are run on layers that are visible in the graphical area. If a layer is in Hide 
mode, no checks will be carried out on that layer. Some checks require multiple layers to 
be visible on screen as they verify the interaction between layers. Other checks simply 
work on a single layer (or physical layer). Warnings are displayed if the appropriate layers 
are not visible on screen. 
 
DFM checks can be run on multiple layers, single layers, or selected areas depending on 
requirements.  
 
Settings for all individual checks can be saved. This saved set of values can be loaded 
and used on any dataset. As the settings are saved as an external file, multiple settings 
can be saved (for example a set of values for standard technology PCB boards and a set 
of values for high technology PCB boards). 
 
Multiple different ‘DFM runs’ can be carried out. A ‘DFM run’ involves running the 
required individual DFM checks on the required data and storing the results generated. 
For example, DFM Run #2 could be running spacing checks on a specific area after fixing 
any DFM errors found during DFM Run #1. The use of multiple DFM runs prevents 
previously found issues being overwritten by subsequent DFM runs. Each DFM run can 
be named and accessed in the DFM Review stage. 
 
The DFM checks are organized in a tree structure and grouped by category. To activate 
a specific check, select the diamond next to the check and then enter the appropriate 
parameters in the Parameters section. 
 

Categories of checks are based on the physical layer type set for each layer along with the sode 
set for a layer. Thus if for example the Silkscreen to Copper check is run for the Top silkscreen 
layer, the software automatically uses the Top Signal layer when performing this check. Checks 
are grouped into the following categories 
 
Signal Layer Checks     Power and Ground Checks  
Drill Checks      Silkscreen Checks  
Solderpaste Checks     Soldermask Checks  
Profile Checks
 
The main DFM Check Category (the root of the category tree) includes global parameters that 
determine the maximum drill size that is considered a via and the minimum copper area (any area 
that has a copper area value less than the parameter is determined to NOT be a plane area). 
 

DFM Setup 
 
Setting up the DFM checks allows manufacturing defects to be detected and fixed prior to the 
manufacturing process. 
 
The DFM Setup Dialog is shown below. It takes the form of a tree structure with checks that are 
performed on the same layer type being grouped together.  



 
Figure 19 

Every DFM check has a set of parameters that determine the results reported back following the 
completion of the DFM Run. 
 
Some checks (Missing Mask Clearance for a Surface mount pad) simply need to be activated and 
do not require a parameter. These types of checks detect the presence or absence of a feature. 
 
Other checks have a single parameter. These checks (Minimum Feature for example) report any 
feature below (or above) this critical value. 
 
Checks that have two parameters use the parameters as boundaries and detect issues that fall 
between these limits. In the Pad Registration check for example, drill holes mis-registered by a 
very small amount can be ignored if the lower boundary is set slightly above zero. 
 
Many Checks have three parameters. This allows the severity of an issue to be determined. 
Violations below parameter 1 are classified as Red, between parameters 1 and 2 as yellow and 
between parameters 2 and 3 as green. Results above parameter 3 are not reported. 
 
Each specific combination of checks can be saved for re-use (save to file button). For example, if 
certain checks are run on customer A’s data and those checks, plus some additional checks, are 
run on customer B’s data, two DFM settings can be saved and accessed though the Load from 
File and Save to File buttons.  
 
The results of any particular set of checks can be saved as a DFM Run. There are five available 
runs and each can be saved with its own name. The results in each DFM Run do not overwrite 
other runs and so a history of DFM results can be kept for any particular job. The different DFM 
runs can be viewed in DFM Results but the results shown following the DFM Setup will be those 



that are chosen through this dialog (in the below case, the results from DFM Run 2 will be 
displayed (note that DFM Run 1 contains results). 

 
Figure 20 

 
Clicking the diamond next to the check or category can activate individual checks or entire 
categories. In the screenshot below all the checks within the Signal Layer, Power Ground, Drill 
and Soldermask categories will be active. Note the partially colored diamond at the DFM Check 
Categories level indicates some, but not all, checks below that entry will be active. Opening up 
the Category Checks shows the individual checks that are active (see the Drill Checks area 
below). 

 
Figure 21 

The parameters section of the dialog shows the current parameters for the highlighted check (or 
all checks within the category). Clicking in the parameter field and typing the required value can 
change parameter values. Error trapping is present to ensure ranges are valid and the error 
message will explain the problem. For details on the individual parameters required for a 
particular check see here.  

 
Figure 22 

The final area of the dialog allows for the setting of the following: 
Parameter units – sets the units for displaying the parameter values 
DFM Selected Only – allows for DFM checks to be run on selected data only. This allows for 
checks to be run on certain areas of the PCB (in the case of tight tolerance areas, or user edited 
areas). 
Use Net Information – If a netlist has been extracted then checking this potion will ignore same 
net spacing violations. 
Layers – For each check the layers to be checked can be defined here. By default all visible 
layers are checked and the layer type is also considered (for instance even though ALL layers are 
defined for Pad to Pad Signal layers, only layers with layer Type Signal will be checked). This 
option does allow for certain specific layers to be tested, if that is the user requirement. 
Load from File – Loads a previously saved set of DFM parameters fro a file stored externally. 
Save to File – Saves the current set of DFM parameters to an external file. 
Run Checks – Runs the current active DFM parameters against the visible layers. 



 
Figure 23 

When Run Checks is selected only checks at or below the highlighted check will be performed. 
This is to save time and offer flexibility to the user. For example, let’s assume that Signal, Drill 
and Soldermask checks were run on a particular PCB. If only Signal layer errors were detected 
and subsequently fixed, the user may want to only run the signal layer checks (and not want to 
turn off all the previously set Drill and Soldermask checks). Highlighting the Signal Layer Checks 
category and selecting Run Checks will achieve this (see below). In the case below only Signal 
layer checks will only be run.  

 
Figure 24 

In order to ensure that the correct checks are run in the cases where only a subset of currently 
activated checks will be carried out the following warning message is presented. 

 
Figure 25 

By selecting Continue only the Signal layer checks will be performed. By selecting Run All 
Enabled, this setting is ignored and all active checks are run. This also occurs at the individual 
check level, enabling single checks to run as required.  
If there are other active checks that are not going to be run settings specify that layer the 
following warning message appears. This is to inform the user that layers will not be checked 
 

 

 

 

 

 

 



DFM Results 
 
The Review DFM graphically presents the results of the DFM analysis as defined in the DFM 
Setup. The Review DFM function is automatically called if the DFM Analysis detects errors. It can 
also be called from the DFM menu (see below)
 
The Review DFM feature consists of three inter-related dialogs: Categories View, Histograms 
View, Results View 
 

 
Figure 26 

 
The inter-relation of the views allows the graphics area to both control and be controlled by the 
view dialogs.  
 
Categories View 
 
The categories dialog shows which categories contain errors. If a category was checked but there 
were no violations detected then that category is not included in the dialog. The tree structure 
nature of the Categories Dialog allows the highlighting of individual categories or groups of 
categories. By clicking on a category heading (for example Solder Mask Checks) or specific 
categories (for example Mask to Mask) the information shown in the Histogram View, Results 
View Summary/Details is automatically updated. If a category heading is highlighted then all 
errors within that category are accessible through the Results View and if a specific check is 
chosen the Results View is filtered to only contain issues related to the specific check. 

http://216.174.208.199/database/onlinesupport/functions/DFM Menu - Review DFM.htm#Open


 
Figure 27 

 
This dialog provides are very simply method of moving between different categories of checks 
and filtering errors based on category or specific check. 
If the DFM view option of ‘Show DFM results within View’ is active then the category list is filtered 
to only include categories that contain violations within the current graphic display.   
 
Histograms View: 
 
The Histogram View displays errors based on specific check and severity. Again, selections 
made within the Histogram View are automatically updated across the Categories View and the 
Results View.  
Each Histogram displays in the appropriate color based on the result obtained. By clicking on a 
specific color band within the Histogram, the information shown in the Summary and Details tabs 
is automatically filtered based on severity. 
 

http://216.174.208.199/database/onlinesupport/functions/DFM%20Menu%20-%20DFM%20View%20Options.htm


 
Figure 28 

 
 
Result View: 
 
The Results View allow navigation through the errors. Navigation occurs within the Details Tab of 
the dialog and the specific error highlighted is then displayed in the Main Graphics Window. You 
can zoom in or out and change layer visibility while viewing the Results View.  
The Results View Details Tab can be sorted based on column by simply clicking on the column 
header – with the default being smallest to largest. 
If an entry is highlighted with the Details Tab and the right mouse button is clicked, a number of 
options become available. A range of errors can be highlighted by holding the shift key when 
defining the required range. 
 

 
Figure 29 

 
Highlighted errors can be selected or unselected. Entities that are tagged as selected are then 
selected within the graphics window. When the DFM Review dialogs are closed, the entities 
remain selected within the job. The option to Select All errors is also provided. Once an error is 
selected,. It can be unselected using the available options. 



In some cases, highlighted errors are of no concern and these errors can be hidden within the 
Results View using the Hide option. These errors can be retrieved again for display using the 
Unhide All option. 
If the highlighted errors are not required to be in the Results View they can be Removed 
Permanently from the Results. 
 
Close the Review DFM function by going to the DFM menu and clicking on the checkmarked 
Review DFM menu entry. 
 

 
Figure 30 

The following dialog will appear.  

 
Figure 31 

 
In this dialog, the following actions can be accomplished 
 
Display a different DFM Run (to possibly display errors using a different set of DFM parameters) 
Change the view options applied to the results – click here for more details. 
Clear all the currently stored DFM results within the selected Run 
 

Exporting Data 
 
In addition to saving data in the GraphiCode GWK workfile format, GC-PowerStation also allows 
the output of RS-274-X, RS-274-D, NC Drill files, basic DXF, HPGL and DPF. We will now simply 
output a couple of RS-274-X (extended Gerber) files to illustrate the ability to translate data with 
GC-PowerStation. 
 

1. From the main menu choose File > Open 
2. Use the file picker to navigate to the ‘Demodata’ directory within the installation directory. 
3. Select the General Navigation.GWK then select Open  
4. Select File > Export 
5. Choose the RS-274-X option 

http://216.174.208.199/database/onlinesupport/functions/DFM%20Menu%20-%20DFM%20View%20Options.htm


6. The Export dialog appears. 
7. To change the units or precision select the setup tab and make the appropriate changes. 
8. In the Page 1 tab, simply enter the output file name in the Output File field and couple 

this with the layer or layers you wish to output to that file. Continue with other layers in 
the same way. You will also notice that by using the Layer picker, you can select multiple 
layers to be output to the same file. Use the Windows standard methods of Shift or 
Control while selecting with the mouse. 

 
 

 
      Figure 32: Export Dialog 

 
9. You can change the default output file directory by canceling and selecting Tools > 

Customize > File Location tab and modifying the Export Directory. 
10. Continue on to Page 2 etc. if you need to output many files.  
11. Select OK. 

 



Chapter 4: Stackup Module 
 

Introduction  
 
Stackup is a new software module from GraphiCode that is a standard part of GC-PowerStation 
and GC-PrevuePlus. It allows PCB builds to be created, edited, and saved in the same 
environment as the image information. This allows designers, and PCB fabricators to edit the 
layer image information or the material build information in the same user friendly, high value 
software product. 
 
This guide is intended to give to a quick flavor of the capabilities of the module. 
 
NOTE 
 
If you have a serial number (dongle) license with a current Annual Support Plan you will be 
able to access the Materials Database and Add / Remove / Modify materials 
 
If you have a demo license you will be able to access the Materials Database but will not 
be able to Add / Remove / Modify materials 
 
If you have a serial number (dongle) license that is out of maintenance you will not be able 
to access any StackupBuilder functionality. 
 
 
If you have any questions at any time throughout this demo, please call your authorized 
GraphiCode reseller. If you have obtained this Demonstration Guide from GraphiCode directly, 
please call 360-282-4888 or email us at sales@graphicode.com. 
 
 



Creating a Stackup Configuration 
 
Let’s create a PCB build for a 4 layer foil construction. This will keep things simple and easy to 
follow. The exact materials you decide to use are not important, but it is important to understand 
the basic process, as it will be applied to other constructions. 
 
There will be no data in the application at this time and this is fine – we’ll use data in a short while 
to make use of the configuration. 
 

1. Start the application, click the Stackup menu and choose ‘Start StackupBuilder’. The 
following dialog appears: 

 

 
Figure 33 

 
As there is no data in the application at this time the only option is ‘Start from Scratch’, so enter 
‘4’ for the # of Signal Layers and Foil Build for the Build Type. Then press OK. 
 

2. The StackupBuilder dialog is displayed with a default four-layer Foil construction.  
 

3. Left click on the Core layer.  (The image below depicts the Core layer): 
 

 
 

4. When selected, any material layer will have two small blue arrows showing that the layer 
is selected. Additionally, various function buttons along the bottom of the screen become 
active. These function buttons can also be accessed by a right mouse click, which will be 
used for this QuickStart Guide. 

 
5. Right click and choose ‘Change Material’. The database of materials (containing a few 

material entries) is displayed. The selected layer is a core, so the default view is core 
material only. The Materials Database is searchable and editable, but for now simply 



select one of the entries in the table, and then click the “Select” button in order to assign 
that material to the stackup: 

 

 
Figure 34 

 
 

6.  Once this material is selected, the graphical display of the stackup is updated with the 
material details, and the thickness of the stack is recalculated. You will notice the 
following information is displayed 

 

 
Figure 35 

 
Total Thickness: Updated to reflect the current available information 
 

Prepreg thickness: Note that in the above case, the value is negative. The negative value 
reflects the amount of pre-preg that is required to fill the spaces between the copper 
image for 1 oz copper. This thickness is a cumulative thickness of prepreg between each 
copper layer and will be updated based upon materials used. 

 
Core thickness and copper weight 

 
7. Change the prepreg material and the foil layers (if no foil materials appear in the 

database, try changing the displayed Vendor). In order to add a second layer of prepreg 
between layer one and two, move the mouse between the foil and the core layers. A faint 
white image of a layer is displayed in order to indicate the space between materials. 
Select this image with a left mouse click.  Red arrows appear, indicating a selected gap. 
Right click to choose the Add Prepreg option, and then select the desired Vendor and 
material from the material list. You will notice that there is still only one thickness value 
displayed showing the combined prepreg thickness between copper layers. 

 
8. Once the materials are entered to your satisfaction, click on the button in the lower right 

hand corner of the screen labeled ‘Save Configuration’. This button allows the current 
configuration to be saved and applied to any four layer set of data in the future. There is 
no limit to the number of configurations that can be saved. We will use this configuration 
in the next part of this QuickStart Guide. 

 
 



9. Finally, there is also an option to create an image in the GWK that illustrates the stackup 
build that has just been created. The button labeled ‘Capture Image to GWK layers’ will 
create a layer in the Unassigned Layers category section of the GWK, providing a 
stylized representation of the build.  

 
10. The stackup image within the Stackup dialog, and the image generated in the 

Unassigned Layers category can be printed using their respective Print buttons. 
 
 

11. Now Quit to go back to the GWK area.  
  



 Applying an existing Configuration 
 
Let’s use the configuration file we just created and apply it to a GWK file that includes pre-loaded 
Gerber data. 
 

1. From the main menu choose File > Open 
2. Use the file picker to navigate to the ‘Examples’ directory within the installation directory..  

The file is called Four_layer_example.gwk then select Open 
3. Notice that the GWK has the layer types assigned to each Gerber layer.  This layer typing 

is important, because the configuration file checks that the correct number of Signal 
layers are present, and also that the TYPE of signal layer is assigned 
(Signal/Mixed/Plane): 

 

 
Figure 36 

 
4. Click the Stackup menu and choose ‘Start StackupBuilder’. The main dialog appears, but 

this time there are several options available because Gerber data is contained within the 
GWK. Choose the ‘Apply Configuration’ option and then click the layer picker to navigate 
to the configuration file you created in the previous section. If you didn’t create a 
configuration file, there is one called my_demo_4layer_foil.cfg included with this guide. 

 
5. Once the configuration file has been selected, an image of an eye is displayed.  Hovering 

the mouse over this image displays the materials to be used by this configuration. 
 

 
Figure 37 

 



6. Click on the button labeled ‘Evaluate’ that appears below the Apply Configuration area. 
After a few seconds of calculation the message should display ‘OK to use True Copper 
area’. As the Gerber data of each of the layers is available to the application, the area of 
each signal layer’s copper is calculated and used to calculate the amount of prepreg that 
will be needed to fill the gaps in the copper pattern. This can provide a more accurate 
calculation than the alternate method of a simple percentage of area. A well-formed 
Outline layer is required in order to utilize this function and if this is not available, or this 
option is not checked, the alternate method is used. 

 
7. Select OK and the Stackup dialog is displayed with the appropriate materials assigned 

along with the calculated thickness. 
 
 

8. In the upper right corner of the application, the General Info tab and the Settings tab are 
displayed. The Settings tab is used to define the preferred vendor that shows within the 
Materials Database as well as the percentages used by the simple copper area 
adjustment algorithm. 

 
 
 
 
Hopefully this section has given some insight to the possibilities of the Stackup module and how it 
can provide a flexible and powerful tool for your organization. Please contact 
sales@graphicode.com with any questions or comments you may have – we welcome your 
feedback. 
 
 
 
 
Conclusion 
 
This demonstration guide for GC-PowerStation has only scratched the surface of what can be 
achieved with this tool. Feel free to investigate further on your own and be sure to let us have any 
constructive feedback so that we can continually improve the products. 
 
Thanks for your time 
 
GraphiCode 
(360) 282-4888 
sales@graphicode.com 

mailto:sales@graphicode.com


Other GraphiCode products 

GC-Services 
GC-Services is more than technical support.  It provides customers with product support, training, 
consulting, and data preparation services. GC-Services provides expertise to elevate employee 
skills, boost manufacturing efficiency, and quickly resolve technical issues. If time or a lack of 
personnel is keeping you from delivering work, GC-Services will do the work for you. 

GC-PowerPlace 
GC-PowerPlace is used by many world-class contract manufacturers and OEMs. PCB assembly 
engineers utilize Gerber data, bill of materials, and/or CAD-XY files to generate pick and place 
programs completely off-line. Centroids are extracted automatically with sub-micron precision so 
accuracy will always be attainable. GC-PowerPlace also creates programs for X-ray inspection 
machines, fluid dispensers, and screen printers. 

GC-PowerStation 
GC-PowerStation serves sophisticated PCB fabricators.  Since 1988, GraphiCode has delivered 
high performance CAM software on the PC and it remains the performance and quality leader on 
the PC platform. GC-PowerStation has all of the features that you expect from a high-end PCB 
CAM system at a fraction of the cost. GC-PowerStation produces data for photoplotters, NC drill 
and rout machines, penplotters and Postscript devices from various data sources. 

GC-PowerStation 
GC-PowerStation meets the needs of PCB designers and entry-level CAM operators who require 
convenient design modification capabilities.  Plus it features all the powerful panelization and 
editing tools necessary for PCB photoplotting, drill and routing, stencil manufacturing, and basic 
design modification.  GC-PowerStation is the low-cost high quality leader for PCB data 
preparation, panelization, and output. 

GC-PrevuePlus 
In response to many inquiries from GC-Prevue users, GraphiCode created GC-PrevuePlus to fill 
the need for an inexpensive Gerber translator and editor. Building on proven functionality from 
GraphiCode's existing family of products, GC-PrevuePlus takes GC-Prevue to the next level.  In 
addition to GC-Prevue’s capabilities, GC-PrevuePlus includes AutoCAD® DXF/DWG import, 
enhanced measurement tools, data editing capabilities and multiple output formats. Users now 
have the answer to verify, translate, edit and convert PCB data files. 

GC-Prevue 
GC-Prevue is GraphiCode’s free data viewer, which is fully compatible with GC-PowerStation, 
GC-PowerPlace, GC-PowerStation, and GC-PrevuePlus. GC-Prevue gives you the ability to 
share the information within the GraphiCode GWK file with any user at no extra cost. Use it as a 
tool on the shop floor to allow colleagues to quickly identify a component by reference designator 
or location.  
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All rights reserved. This material and instructions for use contained herein are the property of 
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